> For the complete documentation index, see [llms.txt](https://navixy.com/docs/llms.txt). Markdown versions of documentation pages are available by appending `.md` to page URLs; this page is available as [Markdown](https://navixy.com/docs/analytics/ru/iot-query/connection-setup/selecting-bi-tools/connecting-power-bi.md).

# Подключение Power BI

Подключите Power BI к IoT Query через коннектор PostgreSQL. Выполняйте запросы к телематическим данным в реальном времени и создавайте интерактивные отчеты и панели мониторинга автопарка

В этой статье мы пошагово разберем процесс подключения Microsoft Power BI к **IoT Query**. Чтобы сделать его более наглядным, мы также создадим панель мониторинга, которая подключается к аналитической базе данных и отслеживает статус Транспорт в реальном времени, все с помощью Microsoft Power BI.

{% hint style="info" %}
Это руководство является частью **IoT Query** набора документации и в частности описывает подключение Power BI к вашему хранилищу данных. Если вы еще выбираете, какой BI-инструмент использовать, обратитесь к [Выбор BI-инструментов](/docs/analytics/ru/iot-query/connection-setup/selecting-bi-tools.md) обзору.
{% endhint %}

## Возможности панели мониторинга

* Показать общее количество Транспорт
* Визуализировать статусы движения транспортных средств (Движется/Остановился/Стоит)
* Визуализировать статусы подключения (активен/в простое/Оффлайн)
* Подробная таблица с текущим статусом всех транспортных средств
* Фильтрация по типу транспортного средства, группе, статусу движения и статусу подключения
* Возможности экспорта данных и отчетов

## Технические требования

* Windows 10/11 или Windows Server 2016+
* Microsoft Power BI Desktop (current version)
* Учетная запись Microsoft для доступа к Power BI Service (необязательно)
* Минимум 4 ГБ ОЗУ (рекомендуется 8 ГБ)
* Доступ в интернет для подключения к базе данных

## Установка и настройка

### 1. Установите Power BI Desktop

1. Скачайте Power BI Desktop с официального сайта Microsoft: <https://powerbi.microsoft.com/desktop/>
2. Запустите установщик и следуйте его инструкциям.

### 2. Скачайте файл панели мониторинга

1. Скачайте [Движется\_status\_dashboard.pbix](https://raw.githubusercontent.com/Navixy/bi-integrations/main/power_bi/moving_status_dashboard.pbix) файл из [репозитория bi-intergrations](https://github.com/Navixy/bi-integrations) -> `power_bi`. Вы можете клонировать весь репозиторий для дальнейших действий:

   ```sh
   git clone https://github.com/Navixy/bi-integrations.git
   ```
2. Откройте скачанный `Движется_status_dashboard.pbix` файл, дважды щелкнув по нему или через меню Power BI Desktop: **File → Open**.

## Подключение к базе данных

### 1. Обновите параметры подключения

1. После открытия файла панели мониторинга перейдите в **Преобразовать данные → Изменить параметры**.
2. Обновите следующие параметры:

* `DB_HOST` - адрес сервера базы данных
* `DB_NAME` - имя базы данных
* `DB_USER` - имя пользователя
* `DB_PASS` - пароль (не сохраняйте файлы с реальными учетными данными в общем доступе)
* `DB_PORT` - порт подключения (по умолчанию 5432)

3. Нажмите **ОК** и примените изменения.

#### Справочник параметров подключения

<table><thead><tr><th width="189.727294921875">Параметр Lakehouse</th><th width="214.1817626953125">Расположение настроек Power BI</th><th>Примечания</th></tr></thead><tbody><tr><td><strong>Хост</strong></td><td><code>DB_HOST</code> параметр</td><td>Адрес сервера базы данных, указанный в приветственном письме</td></tr><tr><td><strong>Порт</strong></td><td><code>DB_PORT</code> параметр</td><td>По умолчанию 5432 для PostgreSQL</td></tr><tr><td><strong>Имя базы данных</strong></td><td><code>DB_NAME</code> параметр</td><td>Назначенное вам имя базы данных</td></tr><tr><td><strong>Имя пользователя</strong></td><td><code>DB_USER</code> параметр</td><td>Ваше имя пользователя базы данных</td></tr><tr><td><strong>Пароль</strong></td><td><code>DB_PASS</code> параметр</td><td>Ваш защищенный пароль базы данных</td></tr><tr><td><strong>Режим SSL</strong></td><td>Настройки подключения</td><td>Установите <strong>require</strong> в диалоговом окне Options</td></tr><tr><td><strong>Схема</strong></td><td>Редактор запросов</td><td>Укажите схему (<strong>raw_business_data</strong> или <strong>raw_telematics_data</strong>) в каждом запросе</td></tr></tbody></table>

### 2. Настройте учетные данные

1. При первом подключении Power BI запросит учетные данные для доступа к базе данных.
2. Выберите **Учетная запись базы данных и пароль** в качестве типа аутентификации.
3. Введите учетные данные, предоставленные вашим администратором.
4. Установите уровень конфиденциальности на **Организация** или **Частный**.

## Использование панели мониторинга

После настройки подключения вы можете:

1. **Обновить данные** - нажмите **Обновить** кнопку на ленте или используйте сочетание клавиш Ctrl+R.
2. **Используйте фильтры** - применяйте фильтры на правой панели или непосредственно на элементах отчета:
   1. Фильтр по типу транспортного средства
   2. Фильтр по группам
   3. Фильтр по статусу Движение/подключение
3. **Переход к детализации данных** - щелкайте по элементам визуализации, чтобы просматривать подробную информацию.
4. **Создавайте закладки** - сохраняйте конкретные настройки фильтров и представления для быстрого доступа.

## Настройка обновления данных

### Локальное обновление

1. В Power BI Desktop откройте меню **Home → Refresh**.
2. Чтобы настроить регулярное обновление через Power BI Service, опубликуйте отчет в Power BI Service.

### Облачное обновление (Power BI Service)

1. (Необязательно) Опубликуйте панель мониторинга в Power BI Service с помощью **Publish** кнопки в Power BI Desktop.
2. В Power BI Service перейдите к настройкам набора данных.
3. В **Scheduled refresh** разделе настройте частоту обновления.
4. Чтобы подключиться к локальной или частной базе данных, вам потребуется установить и настроить Power BI Gateway.

## Устранение неполадок

### Проблемы с подключением к базе данных

* **Ошибка подключения:** Проверьте правильность учетных данных и параметров подключения.
* **Ошибка брандмауэра:** Убедитесь, что ваш IP-адрес добавлен в allowlist для доступа к базе данных.
* **Проблемы с Gateway:** При использовании Power BI Gateway проверьте состояние службы шлюза.

### Проблемы с производительностью

* **Медленная загрузка визуализаций:**
  * Сократите количество одновременно отображаемых элементов
  * Проверьте режим Import/DirectQuery в модели данных
* **Высокое потребление памяти:**
  * Сократите объем импортируемых данных, применяя фильтры на уровне запроса
  * Удалите ненужные столбцы из модели данных

### Другие проблемы

Вот несколько приемов, которые помогут вам решить распространенные проблемы:

1. Снова откройте Power BI Desktop и файл панели мониторинга
2. Проверьте наличие обновлений Power BI Desktop
3. Переустановите Power BI Desktop при необходимости
4. Очистите кэш Power BI: **File → Options → Global → Clear items from cache**

## Следующие шаги

После успешного подключения Power BI к вашему экземпляру Private Telematics Lakehouse рекомендуем вам:

* Изучите доступные схемы данных, ознакомившись с [Обзор схемы](/docs/analytics/ru/iot-query/schema-overview.md) раздел, чтобы лучше понять структуру данных и связи.
* Начните с простых запросов, ориентированных на конкретные бизнес-сущности, прежде чем создавать сложные панели мониторинга, — ознакомьтесь с нашими [примерами запросов](/docs/analytics/ru/example-queries.md) для справки.

### **Поддержка**

По техническим вопросам или запросам на доступ к демонстрационной базе данных, пожалуйста, свяжитесь с: <support@squaregps.com>


---

# Agent Instructions
This documentation is published with GitBook. GitBook is the documentation platform designed so that both humans and AI agents can read, navigate, and reason over technical content effectively. Learn more at gitbook.com.

## Querying This Documentation
If you need additional information that is not directly available in this page, you can query the documentation by asking a question.

Perform an HTTP GET request on the following URL with the `ask` and `goal` query parameters:

```
GET https://navixy.com/docs/analytics/ru/iot-query/connection-setup/selecting-bi-tools/connecting-power-bi.md?ask=<question>&goal=<user_goal>
```

`ask` is the immediate question: it should be specific, self-contained, and written in natural language.
`goal` is what the user is ultimately trying to achieve, the reason they need the answer. Sharing it helps GitBook give you a better, more relevant answer. A goal is most helpful when it describes the outcome the user wants rather than restating the question. For example, with `ask=how do I create an API token`, a goal like `automate deployments from our CI pipeline` lets GitBook tailor the answer to that use case.

The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
